I’ve been working on the v4.1.4 (v4.1.4 is an arbitrary number, something less than 4.2) update for quite a while now and most of it is for compatibility of old iOS versions (iOS 5.1 – iOS 6.x). Version 4.0 was primarily a stopgap for our Alerts being broken in iOS 7 (and tested using the beta…